using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\([^()]*(?:\([^()]*\)[^()]*)*\)";
string input = @"(CD-1)
(mdx (fq) KO)
(SCID)
(tmos (line x11))
(Atm (line G5))";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}