$re = '/\([^()]*(?:\([^()]*\)[^()]*)*\)/';
$str = '(CD-1)
(mdx (fq) KO)
(SCID)
(tmos (line x11))
(Atm (line G5))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);