re = /\([^()]*(?:\([^()]*\)[^()]*)*\)/
str = '(CD-1)
(mdx (fq) KO)
(SCID)
(tmos (line x11))
(Atm (line G5))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end