$re = '/([0-9\/])/';
$str = 'Paga. ref. a nota fiscal número 8888, com o cheque número 9999 em 14/08/2015';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);