re = /([0-9\/])/
str = 'Paga. ref. a nota fiscal número 8888, com o cheque número 9999 em 14/08/2015'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end