use strict;
my $str = 'BIG BOAT , GREEN CAR,BIG BOAT, YELLOW TRUCK, BIG BOAT, AMAZON ECHO, BIG BOAT , BLUE CAR , BIG BOAT BLUE, TABLE, GLASSES, BIG BOAT';
my $regex = qr/(?:^|,\s*)BIG BOAT\s*(?=,|$)/mp;
my $subst = 'TEST';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";