$re = '/(?:^|,\s*)BIG BOAT\s*(?=,|$)/m';
$str = 'BIG BOAT , GREEN CAR,BIG BOAT, YELLOW TRUCK, BIG BOAT, AMAZON ECHO, BIG BOAT , BLUE CAR , BIG BOAT BLUE, TABLE, GLASSES, BIG BOAT';
$subst = "TEST";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;