#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?P<col2>\d{10})|(?![A-Z]{2}\d)\S+)?\s*(?P<col3>[A-Z]{2}\d{6}-\d{4})?[\W_]*(?P<col4>\w.*)"
Local $sString = "1001100100 / hello street 2 a town1" & @CRLF & _
"1001100102 ;hello 3 towns2" & @CRLF & _
"STRZ19-0072 DT001001-0100 location1 town4" & @CRLF & _
"1001100103_hello street 3, town5" & @CRLF & _
"DT001002-0100 street 78" & @CRLF & _
"1001100107 DT001002-0102 street 6a town7"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")