using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?P<col2>\d{10})|(?![A-Z]{2}\d)\S+)?\s*(?P<col3>[A-Z]{2}\d{6}-\d{4})?[\W_]*(?P<col4>\w.*)";
string input = @"1001100100 / hello street 2 a town1
1001100102 ;hello 3 towns2
STRZ19-0072 DT001001-0100 location1 town4
1001100103_hello street 3, town5
DT001002-0100 street 78
1001100107 DT001002-0102 street 6a town7";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}