const regex = new RegExp('^(?:(?P<col2>\\d{10})|(?![A-Z]{2}\\d)\\S+)?\\s*(?P<col3>[A-Z]{2}\\d{6}-\\d{4})?[\\W_]*(?P<col4>\\w.*)', 'gm')
const str = `1001100100 / hello street 2 a town1
1001100102 ;hello 3 towns2
STRZ19-0072 DT001001-0100 location1 town4
1001100103_hello street 3, town5
DT001002-0100 street 78
1001100107 DT001002-0102 street 6a town7`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}