const regex = /(?<=world ).*?(?= world)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=world ).*?(?= world)', 'i')
const str = `our world has a 196 countries, but only 192 of them are UN's member. our world is extra-ordinary.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}