$re = '/(?<=world ).*?(?= world)/i';
$str = 'our world has a 196 countries, but only 192 of them are UN\'s member. our world is extra-ordinary.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);