re = /(?<=world ).*?(?= world)/i
str = 'our world has a 196 countries, but only 192 of them are UN\'s member. our world is extra-ordinary.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end