use strict;
my $str = '193.172.166.20
193.172.166.99
193.172.166.100
193.172.166.151
193.172.166.155
193.172.166.200
193.172.166.251
193.172.166.252';
my $regex = qr/^193\.172\.166\.(1[0-9][0-9]|2[0-4][0-9]|25[0-1])$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}