using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)(\w+)\s+(\w+)\s+(\d+)(\w+)\s+(\d+)(\w+)";
string input = @"20E WED 01PM 0E";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}