import Foundation
let pattern = #"(\d+)(\w+)\s+(\w+)\s+(\d+)(\w+)\s+(\d+)(\w+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"20E WED 01PM 0E"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}