$re = '/(\d+)(\w+)\s+(\w+)\s+(\d+)(\w+)\s+(\d+)(\w+)/';
$str = '20E WED 01PM 0E';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);