using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?si)<[\w:]+(?=(?:[^>""']|""[^""]*""|'[^']*')*?(?<=\s)href\s*=\s*(?:(['""])\s*((?:(?!\1).)*?/namehere/nane2here/(?:option1|option2)(?:(?!\1).)*)\s*\1))\s+(?:"".*?""|'.*?'|[^>]*?)+>";
string input = @"<link rel=""apple-touch-icon"" href= "" //bits.wikimedia.org//namehere/nane2here/option2asdf"" />
<div>adasdsda<div>...lots of tags here... <a ... href=""/name/name/option1/data1/data2""...anything here ..."">src</a>...others HTML text here...<a ... href=""/namehere/nane2here/option2/data1""...>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}