const regex = new RegExp('(?si)<[\\w:]+(?=(?:[^>"\\']|"[^"]*"|\\'[^\\']*\\')*?(?<=\\s)href\\s*=\\s*(?:([\\'"])\\s*((?:(?!\\1).)*?/namehere/nane2here/(?:option1|option2)(?:(?!\\1).)*)\\s*\\1))\\s+(?:".*?"|\\'.*?\\'|[^>]*?)+>', 'g')
const str = `<link rel="apple-touch-icon" href= " //bits.wikimedia.org//namehere/nane2here/option2asdf" />
<div>adasdsda<div>...lots of tags here... <a ... href="/name/name/option1/data1/data2"...anything here ...">src</a>...others HTML text here...<a ... href="/namehere/nane2here/option2/data1"...>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}