import re
regex = re.compile(r"(?si)<[\w:]+(?=(?:[^>\"']|\"[^\"]*\"|'[^']*')*?(?<=\s)href\s*=\s*(?:(['\"])\s*((?:(?!\1).)*?/namehere/nane2here/(?:option1|option2)(?:(?!\1).)*)\s*\1))\s+(?:\".*?\"|'.*?'|[^>]*?)+>")
test_str = ("<link rel=\"apple-touch-icon\" href= \" //bits.wikimedia.org//namehere/nane2here/option2asdf\" />\n\n\n"
"<div>adasdsda<div>...lots of tags here... <a ... href=\"/name/name/option1/data1/data2\"...anything here ...\">src</a>...others HTML text here...<a ... href=\"/namehere/nane2here/option2/data1\"...>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")