# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?P<date>[\d\-]{10})\s?(?P<time>[\d\:]{8}\.\d{3}).+?(\[.*?\]).+(<(.*?)>?\((.*?)\).+(\"(\w+)\").+\((\d{,10}\.\d{3}\s?\w{,3})\)).+(\d{2}\.\d{,3}\s\w+)$"
test_str = "2020-08-14 14:24:16.635 <0.8409.0> [notice] [PHm4QqJJ-t2-RB:0] <[s] API exit> END 217b948f.856614 (inflow out) \"RefreshTenantCache\" (5252.994 ms) 10.989 ms"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.