re = /^(?P<date>[\d\-]{10})\s?(?P<time>[\d\:]{8}\.\d{3}).+?(\[.*?\]).+(<(.*?)>?\((.*?)\).+(\"(\w+)\").+\((\d{,10}\.\d{3}\s?\w{,3})\)).+(\d{2}\.\d{,3}\s\w+)$/m
str = '2020-08-14 14:24:16.635 <0.8409.0> [notice] [PHm4QqJJ-t2-RB:0] <[s] API exit> END 217b948f.856614 (inflow out) "RefreshTenantCache" (5252.994 ms) 10.989 ms'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end