import Foundation
let pattern = #"^(?P<date>[\d\-]{10})\s?(?P<time>[\d\:]{8}\.\d{3}).+?(\[.*?\]).+(<(.*?)>?\((.*?)\).+(\"(\w+)\").+\((\d{,10}\.\d{3}\s?\w{,3})\)).+(\d{2}\.\d{,3}\s\w+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"2020-08-14 14:24:16.635 <0.8409.0> [notice] [PHm4QqJJ-t2-RB:0] <[s] API exit> END 217b948f.856614 (inflow out) "RefreshTenantCache" (5252.994 ms) 10.989 ms"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)