import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<date>[\\d\\-]{10})\\s?(?P<time>[\\d\\:]{8}\\.\\d{3}).+?(\\[.*?\\]).+(<(.*?)>?\\((.*?)\\).+(?:\\\"(?P<apiname>\\w+)\\\").+\\((\\d\\{,10\\}\\.\\d{3}\\s?\\w\\{,3\\})\\)).+(\\d{2}\\.\\d\\{,3\\}\\s\\w+)$";
final String string = "2020-08-14 14:24:16.635 <0.8409.0> [notice] [PHm4QqJJ-t2-RB:0] <[s] API exit> END 217b948f.856614 (inflow out) \"RefreshTenantCache\" (5252.994 ms) 10.989 ms";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}