const regex = new RegExp('^(?P<date>[\\d\\-]{10})\\s?(?P<time>[\\d\\:]{8}\\.\\d{3}).+?(\\[.*?\\]).+(<(.*?)>?\\((.*?)\\).+(?:\\"(?P<apiname>\\w+)\\").+\\((\\d{,10}\\.\\d{3}\\s?\\w{,3})\\)).+(\\d{2}\\.\\d{,3}\\s\\w+)$', 'gm')
const str = `2020-08-14 14:24:16.635 <0.8409.0> [notice] [PHm4QqJJ-t2-RB:0] <[s] API exit> END 217b948f.856614 (inflow out) "RefreshTenantCache" (5252.994 ms) 10.989 ms`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}