use strict;
my $str = '2020-08-14 14:24:16.635 <0.8409.0> [notice] [PHm4QqJJ-t2-RB:0] <[s] API exit> END 217b948f.856614 (inflow out) "RefreshTenantCache" (5252.994 ms) 10.989 ms';
my $regex = qr/^(?P<date>[\d\-]{10})\s?(?P<time>[\d\:]{8}\.\d{3}).+?(\[.*?\]).+(<(.*?)>?\((.*?)\).+(?:\"(?P<apiname>\w+)\").+\((\d{,10}\.\d{3}\s?\w{,3})\)).+(\d{2}\.\d{,3}\s\w+)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}