#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)\s*on\s*(?!.*on)"
Local $sString = "Syed on Arafath on Jan 7, 2015" & @CRLF & _
"" & @CRLF & _
"Capt.KSD on Dec 30, 2014" & @CRLF & _
"" & @CRLF & _
"chakradharalasakani on Dec 29, 2014" & @CRLF & _
"" & @CRLF & _
"mitesh0123 on Dec 18, 2014" & @CRLF & _
"" & @CRLF & _
"Aparajita61@yahoo.in on Dec 3, 2014" & @CRLF & _
"" & @CRLF & _
"123chetan on Oct 28, 2014"
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)