import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*on\\s*(?!.*on)";
final String string = "Syed on Arafath on Jan 7, 2015\n\n"
+ "Capt.KSD on Dec 30, 2014\n\n"
+ "chakradharalasakani on Dec 29, 2014\n\n"
+ "mitesh0123 on Dec 18, 2014\n\n"
+ "Aparajita61@yahoo.in on Dec 3, 2014\n\n"
+ "123chetan on Oct 28, 2014";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}