using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\S+)\s+";
string substitution = @"$1\t";
string input = @"2014-05-09 12:28:06 Lab bench another
2014-06-10 01:28:31 Membrane test initiated
2014-05-11 12:38:04 Membrane test initiated
2014-05-13 14:38:06 Membrane test initiated
2014-05-13 12:38:17 Membrane capacitance
2014-05-14 16:38:17 Membrane resistance ";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}