$re = '/^\d+(?:[.,]\d+)*$/m';
$str = '1234
1,234
1.234
1,23,334
1.23.334
1,23,334.00
1.23.334,00
1,23...233
1,23.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);