// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d+(?:[.,]\d+)*$").unwrap();
let string = "1234
1,234
1.234
1,23,334
1.23.334
1,23,334.00
1.23.334,00
1,23...233
1,23.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}