const regex = /.{5}(?!$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.{5}(?!$)', 'gm')
const str = `OBKFA4F26ORJI3ALFYI3QB4ZN`;
const subst = `$0-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);