$re = '/.{5}(?!$)/m';
$str = 'OBKFA4F26ORJI3ALFYI3QB4ZN';
$subst = "$0-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;