use strict;
my $str = 'OBKFA4F26ORJI3ALFYI3QB4ZN';
my $regex = qr/.{5}(?!$)/mp;
my $subst = '$0-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";