#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s).*?(?:A(?![^\r\n]{7})(?:[\r\n]*[^\r\n]){5}[\r\n]*){4,}.*"
Local $sString = "0000000" & @CRLF & _
"0000000" & @CRLF & _
"000A000" & @CRLF & _
"00AB000" & @CRLF & _
"AAAB000" & @CRLF & _
"ABBB000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")