const regex = /.*?(?:A(?![^\r\n]{7})(?:[\r\n]*[^\r\n]){5}[\r\n]*){4,}.*/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?(?:A(?![^\\r\\n]{7})(?:[\\r\\n]*[^\\r\\n]){5}[\\r\\n]*){4,}.*', 's')
const str = `0000000
0000000
000A000
00AB000
AAAB000
ABBB000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}