re = /.*?(?:A(?![^\r\n]{7})(?:[\r\n]*[^\r\n]){5}[\r\n]*){4,}.*/
str = '0000000
0000000
000A000
00AB000
AAAB000
ABBB000'
# Print the match result
str.match(re) do |match|
puts match.to_s
end