use strict;
my $str = 'I\'m very new to regex and there is something that I really just don\'t get. Say I have a regex that matches currency in the form $ddd.dd with an optional .dd, which would be ^[$][0-9]{1,3}(\\.[0-9]{2})?$. The ^ start and $ end ensure that it won\'t match a substring in a string like "$45.3242" or "3499,391". But at the same time, what if I want to match a substring in a string like "I have $400 in my bank account" or "This TV costs $300"? It won\'t match those either. So I am confused on how I should handle both cases. Is it just one or the other, ^ and $ or no ^ and $? I\'d be grateful for any and all advice. Thank you all! $12.34.';
my $regex = qr/\$\d++(?:\.\d{2}\b|(?!\.\d))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}