import Foundation
let pattern = #"\$\d++(?:\.\d{2}\b|(?!\.\d))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"I'm very new to regex and there is something that I really just don't get. Say I have a regex that matches currency in the form $ddd.dd with an optional .dd, which would be ^[$][0-9]{1,3}(\.[0-9]{2})?$. The ^ start and $ end ensure that it won't match a substring in a string like "$45.3242" or "3499,391". But at the same time, what if I want to match a substring in a string like "I have $400 in my bank account" or "This TV costs $300"? It won't match those either. So I am confused on how I should handle both cases. Is it just one or the other, ^ and $ or no ^ and $? I'd be grateful for any and all advice. Thank you all! $12.34."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)