$re = '/\$\d++(?:\.\d{2}\b|(?!\.\d))/';
$str = 'I\'m very new to regex and there is something that I really just don\'t get. Say I have a regex that matches currency in the form $ddd.dd with an optional .dd, which would be ^[$][0-9]{1,3}(\\.[0-9]{2})?$. The ^ start and $ end ensure that it won\'t match a substring in a string like "$45.3242" or "3499,391". But at the same time, what if I want to match a substring in a string like "I have $400 in my bank account" or "This TV costs $300"? It won\'t match those either. So I am confused on how I should handle both cases. Is it just one or the other, ^ and $ or no ^ and $? I\'d be grateful for any and all advice. Thank you all! $12.34.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);