#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:https?:\/\/)?(?:(?:25[0-5]|(?:2[0-4]|1\d|[1-9]|)\d)(?:\.(?!$)|$)){4}|(?:https?:\/\/(?:www\.)?)?[a-z0-9]+(?:[-.][a-z0-9]+)*\.[a-z]{2,5}(?::[0-9]{1,5})?(?:\/.*)?)$"
Local $sString = "example.com" & @CRLF & _
"www.example.com" & @CRLF & _
"http://example.com" & @CRLF & _
"http://www.example.com" & @CRLF & _
"https://example.com" & @CRLF & _
"https://www.example.com" & @CRLF & _
"65.98.157.52" & @CRLF & _
"However, I'm trying to also include these 2 variations:" & @CRLF & _
"" & @CRLF & _
"http://65.98.157.52" & @CRLF & _
"https://65.98.157.52"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")