import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:https?:\\/\\/)?(?:(?:25[0-5]|(?:2[0-4]|1\\d|[1-9]|)\\d)(?:\\.(?!$)|$)){4}|(?:https?:\\/\\/(?:www\\.)?)?[a-z0-9]+(?:[-.][a-z0-9]+)*\\.[a-z]{2,5}(?::[0-9]{1,5})?(?:\\/.*)?)$";
final String string = "example.com\n"
+ "www.example.com\n"
+ "http://example.com\n"
+ "http://www.example.com\n"
+ "https://example.com\n"
+ "https://www.example.com\n"
+ "65.98.157.52\n"
+ "However, I'm trying to also include these 2 variations:\n\n"
+ "http://65.98.157.52\n"
+ "https://65.98.157.52";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}