$re = '/^(?:(?:https?:\/\/)?(?:(?:25[0-5]|(?:2[0-4]|1\d|[1-9]|)\d)(?:\.(?!$)|$)){4}|(?:https?:\/\/(?:www\.)?)?[a-z0-9]+(?:[-.][a-z0-9]+)*\.[a-z]{2,5}(?::[0-9]{1,5})?(?:\/.*)?)$/m';
$str = 'example.com
www.example.com
http://example.com
http://www.example.com
https://example.com
https://www.example.com
65.98.157.52
However, I\'m trying to also include these 2 variations:
http://65.98.157.52
https://65.98.157.52';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);