#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*\/(.+)(\.html|\/)$"
Local $sString = "" & @CRLF & _
"можно убрать экранирование слеша поскольку оно не требуется для апача ( текущий интерпретатор php, мод_реврайт синтаксиса тут нет ;(" & @CRLF & _
"Как мы видимм все что нам нужно попадает в первую группу и мы можем привести все окончания ссылок к единому образцу" & @CRLF & _
"" & @CRLF & _
"ававафвыю.ru/fdfadsfad.html" & @CRLF & _
"афывавфыавыфавф.ru/3effdfadsdfa/dsfadfa/dsfasdf/asdfasd/fasdfasdfa/fadfadsff.html/" & @CRLF & _
"афывавфыавыфавф.ru/3effdfadsdfa/dsfadfa/dsfasdf/asdfasd/fasdfasdfa/fadfadsff.html" & @CRLF & _
"афывавфыавыфавф.ru/3effdfadsdfa/dsfadfa/dsfasdf/asdfasd/fasdfasdfa/fadfadsff/" & @CRLF & _
"" & @CRLF & _
"При таких расклада регулярка не работает нет в ТЗ" & @CRLF & _
"" & @CRLF & _
"фывавфыавыфавф.ru/3effdfadsdfa/dsfadfa/dsfasdf/asdfasd/fasdfasdfa/fadfadsff " & @CRLF & _
"Поскльку конец нас устраивает" & @CRLF & _
"" & @CRLF & _
"При таких расклада регулярка не работает но тебыло в тз" & @CRLF & _
"" & @CRLF & _
"фывавфыавыфавф.ru/3effdfadsdfa/dsfadfa/dsfasdf/asdfasd/fasdfasdfa/fadfadsff.html/" & @CRLF & _
"фывавфыавыфавф.ru/3effdfadsdfa/dsfadfa/dsfasdf/asdfasd/fasdfasdfa/fadfadsff.htm" & @CRLF & _
"Поскольку таких не бывает." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Как мы видим в группу $1 попадает нужная часть урла " & @CRLF & _
"$2 тупо нам не нужна мы ее удаляем." & @CRLF & _
"" & @CRLF & _
"Теперь по твоим регуляркам, у тебя ошибка ты почему то используешь (.*) - любое включая пусто" & @CRLF & _
"А нужно (.+) посколкьу это полразумевает 1 символ как минимум." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" регулярка без экрана слешей .*/(.+)(\.html|/)$" & @CRLF & _
"ну и по идее в апаче сработает такая" & @CRLF & _
"регулярка без экрана слешей .*/(.+)(\.html|/|)$" & @CRLF & _
"ей можно выбрать и еще /fadfadsff окончание, то есть одним правилом схватить сразу все варианты, но нужно проверить."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")