use strict;
my $str = '
можно убрать экранирование слеша поскольку оно не требуется для апача ( текущий интерпретатор php, мод_реврайт синтаксиса тут нет ;(
Как мы видимм все что нам нужно попадает в первую группу и мы можем привести все окончания ссылок к единому образцу
ававафвыю.ru/fdfadsfad.html
афывавфыавыфавф.ru/3effdfadsdfa/dsfadfa/dsfasdf/asdfasd/fasdfasdfa/fadfadsff.html/
афывавфыавыфавф.ru/3effdfadsdfa/dsfadfa/dsfasdf/asdfasd/fasdfasdfa/fadfadsff.html
афывавфыавыфавф.ru/3effdfadsdfa/dsfadfa/dsfasdf/asdfasd/fasdfasdfa/fadfadsff/
При таких расклада регулярка не работает нет в ТЗ
фывавфыавыфавф.ru/3effdfadsdfa/dsfadfa/dsfasdf/asdfasd/fasdfasdfa/fadfadsff
Поскльку конец нас устраивает
При таких расклада регулярка не работает но тебыло в тз
фывавфыавыфавф.ru/3effdfadsdfa/dsfadfa/dsfasdf/asdfasd/fasdfasdfa/fadfadsff.html/
фывавфыавыфавф.ru/3effdfadsdfa/dsfadfa/dsfasdf/asdfasd/fasdfasdfa/fadfadsff.htm
Поскольку таких не бывает.
Как мы видим в группу $1 попадает нужная часть урла
$2 тупо нам не нужна мы ее удаляем.
Теперь по твоим регуляркам, у тебя ошибка ты почему то используешь (.*) - любое включая пусто
А нужно (.+) посколкьу это полразумевает 1 символ как минимум.
регулярка без экрана слешей .*/(.+)(\\.html|/)$
ну и по идее в апаче сработает такая
регулярка без экрана слешей .*/(.+)(\\.html|/|)$
ей можно выбрать и еще /fadfadsff окончание, то есть одним правилом схватить сразу все варианты, но нужно проверить.';
my $regex = qr/.*\/(.+)(\.html|\/)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}