# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*\/(.+)(\.html|\/)$"
test_str = ("\n"
"можно убрать экранирование слеша поскольку оно не требуется для апача ( текущий интерпретатор php, мод_реврайт синтаксиса тут нет ;(\n"
"Как мы видимм все что нам нужно попадает в первую группу и мы можем привести все окончания ссылок к единому образцу\n\n"
"ававафвыю.ru/fdfadsfad.html\n"
"афывавфыавыфавф.ru/3effdfadsdfa/dsfadfa/dsfasdf/asdfasd/fasdfasdfa/fadfadsff.html/\n"
"афывавфыавыфавф.ru/3effdfadsdfa/dsfadfa/dsfasdf/asdfasd/fasdfasdfa/fadfadsff.html\n"
"афывавфыавыфавф.ru/3effdfadsdfa/dsfadfa/dsfasdf/asdfasd/fasdfasdfa/fadfadsff/\n\n"
"При таких расклада регулярка не работает нет в ТЗ\n\n"
"фывавфыавыфавф.ru/3effdfadsdfa/dsfadfa/dsfasdf/asdfasd/fasdfasdfa/fadfadsff \n"
"Поскльку конец нас устраивает\n\n"
"При таких расклада регулярка не работает но тебыло в тз\n\n"
"фывавфыавыфавф.ru/3effdfadsdfa/dsfadfa/dsfasdf/asdfasd/fasdfasdfa/fadfadsff.html/\n"
"фывавфыавыфавф.ru/3effdfadsdfa/dsfadfa/dsfasdf/asdfasd/fasdfasdfa/fadfadsff.htm\n"
"Поскольку таких не бывает.\n\n\n"
"Как мы видим в группу $1 попадает нужная часть урла \n"
"$2 тупо нам не нужна мы ее удаляем.\n\n"
"Теперь по твоим регуляркам, у тебя ошибка ты почему то используешь (.*) - любое включая пусто\n"
"А нужно (.+) посколкьу это полразумевает 1 символ как минимум.\n\n\n"
" регулярка без экрана слешей .*/(.+)(\\.html|/)$\n"
"ну и по идее в апаче сработает такая\n"
"регулярка без экрана слешей .*/(.+)(\\.html|/|)$\n"
"ей можно выбрать и еще /fadfadsff окончание, то есть одним правилом схватить сразу все варианты, но нужно проверить.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.