$re = '/<img\s+src="([^"]+)"\s+width="([^"]+)"\s+height="([^"]+)"/';
$str = '<img src="myurl.jpg" width="12" height="32">';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);