re = /<img\s+src="([^"]+)"\s+width="([^"]+)"\s+height="([^"]+)"/
str = '<img src="myurl.jpg" width="12" height="32">'
# Print the match result
str.match(re) do |match|
puts match.to_s
end