import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "package\\s+(?:\\w+\\s+)?([^\\s]+)\\s+is(.*?)end\\s+(package|\\1)\\s*;";
final String string = "package p_dio_bfm is\n"
+ " procedure setBFMCmd ( \n"
+ " variable pin : in tBFMCmd\n"
+ " );\n"
+ "end p_dio_bfm; -- end package;\n\n"
+ "package body p_dio_bfm is\n"
+ " procedure setBFMCmd ( \n"
+ " variable pin : in tBFMCmd\n"
+ " ) is\n"
+ " begin\n"
+ " bfm_cmd := pin;\n"
+ " end setBFMCmd;\n"
+ "end p_dio_bfm;";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}