import re
regex = re.compile(r"package\s+(?:\w+\s+)?([^\s]+)\s+is(.*?)end\s+(package|\1)\s*;", flags=re.DOTALL)
test_str = ("package p_dio_bfm is\n"
" procedure setBFMCmd ( \n"
" variable pin : in tBFMCmd\n"
" );\n"
"end p_dio_bfm; -- end package;\n\n"
"package body p_dio_bfm is\n"
" procedure setBFMCmd ( \n"
" variable pin : in tBFMCmd\n"
" ) is\n"
" begin\n"
" bfm_cmd := pin;\n"
" end setBFMCmd;\n"
"end p_dio_bfm;")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")